import Foundation
let pattern = #"(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)(?:;(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)){3}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"1,2;2,3;4,5;0,3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"1-9"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)