import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:0|[1-9]\\d*+),(?:0|[1-9]\\d*+)(?:;(?:0|[1-9]\\d*+),(?:0|[1-9]\\d*+)){3}";
final String string = "1,2;2,3;4,5;0,3";
final String subst = "1-9";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}