const regex = /(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)(?:;(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)){3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:0|[1-9]\\d*+),(?:0|[1-9]\\d*+)(?:;(?:0|[1-9]\\d*+),(?:0|[1-9]\\d*+)){3}', 'g')
const str = `1,2;2,3;4,5;0,3`;
const subst = `1-9`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);