// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)(?:;(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)){3}").unwrap();
let string = "1,2;2,3;4,5;0,3";
let substitution = "1-9";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}