using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)(?:;(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)){3}";
string substitution = @"1-9";
string input = @"1,2;2,3;4,5;0,3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}