re = /(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)(?:;(?:0|[1-9]\d*+),(?:0|[1-9]\d*+)){3}/
str = '1,2;2,3;4,5;0,3'
subst = '1-9'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result