using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-](?:(a)|(bc))+([+-x\/](?:(a)|(bc))+)*$";
string substitution = @"";
string input = @"+a-bc-a
-bc+a-a
-b+a+ab";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}