re = /^[+-](?:(a)|(bc))+([+-x\/](?:(a)|(bc))+)*$/m
str = '+a-bc-a
-bc+a-a
-b+a+ab'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result