import re
regex = re.compile(r"^[+-](?:(a)|(bc))+([+-x\/](?:(a)|(bc))+)*$", flags=re.MULTILINE)
test_str = ("+a-bc-a\n"
"-bc+a-a\n"
"-b+a+ab")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)