$re = '/^[+-](?:(a)|(bc))+([+-x\/](?:(a)|(bc))+)*$/m';
$str = '+a-bc-a
-bc+a-a
-b+a+ab';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;