// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[+-](?:(a)|(bc))+([+-x\/](?:(a)|(bc))+)*$").unwrap();
let string = "+a-bc-a
-bc+a-a
-b+a+ab";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}