package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-](?:(a)|(bc))+([+-x\/](?:(a)|(bc))+)*$`)
var str = `+a-bc-a
-bc+a-a
-b+a+ab`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}