use strict;
my $str = '+a-bc-a
-bc+a-a
-b+a+ab';
my $regex = qr/^[+-](?:(a)|(bc))+([+-x\/](?:(a)|(bc))+)*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";