# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-z ]+//g;t' <<< "Regal Crown Center Stadium 14
Regal Crown Center 14 Stadium"