use strict;
my $str = 'Regal Crown Center Stadium 14
Regal Crown Center 14 Stadium';
my $regex = qr/[a-z ]+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";