#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[a-z ]+"
Local $sString = "Regal Crown Center Stadium 14" & @CRLF & _
"Regal Crown Center 14 Stadium"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)