#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\t:]*(from (.*) |)import (.*?)[\n]"
Local $sString = "import os" & @CRLF & _
"from os import test" & @CRLF & _
"for i in range(50):import os" & @CRLF & _
" import os" & @CRLF & _
" for i in range(50):" & @CRLF & _
" import os" & @CRLF & _
" print("We are importing this new, import ajid.")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")