// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\t:]*(from (.*) |)import (.*?)[\n]").unwrap();
let string = "import os
from os import test
for i in range(50):import os
import os
for i in range(50):
import os
print(\"We are importing this new, import ajid.\")";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}