$re = '`[\t:]*(from (.*) |)import (.*?)[\n]`m';
$str = 'import os
from os import test
for i in range(50):import os
import os
for i in range(50):
import os
print("We are importing this new, import ajid.")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);