const regex = new RegExp('[\\t:]*(from (.*) |)import (.*?)[\\n]', 'gm')
const str = `import os
from os import test
for i in range(50):import os
import os
for i in range(50):
import os
print("We are importing this new, import ajid.")`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}