import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\t:]*(from (.*) |)import (.*?)[\\n]";
final String string = "import os\n"
+ "from os import test\n"
+ "for i in range(50):import os\n"
+ " import os\n"
+ " for i in range(50):\n"
+ " import os\n"
+ " print(\"We are importing this new, import ajid.\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}