using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\t:]*(from (.*) |)import (.*?)[\n]";
string input = @"import os
from os import test
for i in range(50):import os
import os
for i in range(50):
import os
print(""We are importing this new, import ajid."")";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}