#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Parking.*\s.*formula\sfield\s.{9}(.*)<\/span><\/td>"
Local $sString = "Parking: </span></td>" & @CRLF & _
"<td class="d124m43" colspan="5"><span class="formula field d124m23">No Garage, Street Parking</span></td>" & @CRLF & _
"<td class="d124m3"></td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="d124m3"></td>" & @CRLF & _
"<td class="d124m27" colspan="6"><span class="formula field d124m32"><hr></span></td>" & @CRLF & _
"<td class="d124m3"></td></tr>" & @CRLF & _
"<tr class="d124m21">" & @CRLF & _
"<td class="d124m3"></td>" & @CRLF & _
"<td class="d124m4"><span class="label d124m23">Utilities: </span></td>" & @CRLF & _
"<td class="d124m43" colspan="5"> <span class="formula field d124m23">Central Air</span></td>" & @CRLF & _
"<td class="d124m3"></td></tr>" & @CRLF & _
"<tr>" & @CRLF & _
"<td class="d124m3"></td>" & @CRLF & _
"<td class="d124m27" colspan="6"><span class="formula field d124m32"><hr></span></td>" & @CRLF & _
"<td class="d124m3"></td></tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")