import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Parking.*\\s.*formula\\sfield\\s.{9}(.*)<\\/span><\\/td>";
final String string = "Parking: </span></td>\n"
+ "<td class=\"d124m43\" colspan=\"5\"><span class=\"formula field d124m23\">No Garage, Street Parking</span></td>\n"
+ "<td class=\"d124m3\"></td></tr>\n"
+ "<tr>\n"
+ "<td class=\"d124m3\"></td>\n"
+ "<td class=\"d124m27\" colspan=\"6\"><span class=\"formula field d124m32\"><hr></span></td>\n"
+ "<td class=\"d124m3\"></td></tr>\n"
+ "<tr class=\"d124m21\">\n"
+ "<td class=\"d124m3\"></td>\n"
+ "<td class=\"d124m4\"><span class=\"label d124m23\">Utilities: </span></td>\n"
+ "<td class=\"d124m43\" colspan=\"5\"> <span class=\"formula field d124m23\">Central Air</span></td>\n"
+ "<td class=\"d124m3\"></td></tr>\n"
+ "<tr>\n"
+ "<td class=\"d124m3\"></td>\n"
+ "<td class=\"d124m27\" colspan=\"6\"><span class=\"formula field d124m32\"><hr></span></td>\n"
+ "<td class=\"d124m3\"></td></tr>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}