import re
regex = re.compile(r"Parking.*\s.*formula\sfield\s.{9}(.*)<\/span><\/td>")
test_str = ("Parking: </span></td>\n"
"<td class=\"d124m43\" colspan=\"5\"><span class=\"formula field d124m23\">No Garage, Street Parking</span></td>\n"
"<td class=\"d124m3\"></td></tr>\n"
"<tr>\n"
"<td class=\"d124m3\"></td>\n"
"<td class=\"d124m27\" colspan=\"6\"><span class=\"formula field d124m32\"><hr></span></td>\n"
"<td class=\"d124m3\"></td></tr>\n"
"<tr class=\"d124m21\">\n"
"<td class=\"d124m3\"></td>\n"
"<td class=\"d124m4\"><span class=\"label d124m23\">Utilities: </span></td>\n"
"<td class=\"d124m43\" colspan=\"5\"> <span class=\"formula field d124m23\">Central Air</span></td>\n"
"<td class=\"d124m3\"></td></tr>\n"
"<tr>\n"
"<td class=\"d124m3\"></td>\n"
"<td class=\"d124m27\" colspan=\"6\"><span class=\"formula field d124m32\"><hr></span></td>\n"
"<td class=\"d124m3\"></td></tr>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")