# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:All DLC BG|DLC Comfort)\b(*SKIP)(*FAIL)|\bDLC\b//gm;t' <<< "test All DLC BG test DLC Comfort and DLC here
test here All DLC BG All DLC BG BG ALL DLC"