import Foundation
let pattern = #"\b(?:All DLC BG|DLC Comfort)\b(*SKIP)(*FAIL)|\bDLC\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test All DLC BG test DLC Comfort and DLC here
test here All DLC BG All DLC BG BG ALL DLC
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)