use strict;
my $str = 'test All DLC BG test DLC Comfort and DLC here
test here All DLC BG All DLC BG BG ALL DLC';
my $regex = qr/\b(?:All DLC BG|DLC Comfort)\b(*SKIP)(*FAIL)|\bDLC\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";