import re
regex = re.compile(r"\b(?:All DLC BG|DLC Comfort)\b(*SKIP)(*FAIL)|\bDLC\b", flags=re.MULTILINE)
test_str = ("test All DLC BG test DLC Comfort and DLC here\n\n"
"test here All DLC BG All DLC BG BG ALL DLC")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)