re = /\b(?:All DLC BG|DLC Comfort)\b(*SKIP)(*FAIL)|\bDLC\b/m
str = 'test All DLC BG test DLC Comfort and DLC here
test here All DLC BG All DLC BG BG ALL DLC'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result