const regex = /\b(?:All DLC BG|DLC Comfort)\b(*SKIP)(*FAIL)|\bDLC\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:All DLC BG|DLC Comfort)\\b(*SKIP)(*FAIL)|\\bDLC\\b', 'gm')
const str = `test All DLC BG test DLC Comfort and DLC here
test here All DLC BG All DLC BG BG ALL DLC`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);