package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_thumb(@[2-3]x)?\.jpg`)
var str = `grwior_thumb.jpg
grwior.jpg
vuoetrjrt_thumb@2x.jpg
vuoetrjrt.jpg
hafiruwhf_thumb.jpg
hafiruwhf_thumb@2x.jpg
hafiruwhf_thumb@3x.jpg
hafiruwhf.jpg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}