use strict;
my $str = 'grwior_thumb.jpg
grwior.jpg
vuoetrjrt_thumb@2x.jpg
vuoetrjrt.jpg
hafiruwhf_thumb.jpg
hafiruwhf_thumb@2x.jpg
hafiruwhf_thumb@3x.jpg
hafiruwhf.jpg
';
my $regex = qr/_thumb(@[2-3]x)?\.jpg/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}