const regex = /_thumb(@[2-3]x)?\.jpg/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('_thumb(@[2-3]x)?\\.jpg', 'g')
const str = `grwior_thumb.jpg
grwior.jpg
vuoetrjrt_thumb@2x.jpg
vuoetrjrt.jpg
hafiruwhf_thumb.jpg
hafiruwhf_thumb@2x.jpg
hafiruwhf_thumb@3x.jpg
hafiruwhf.jpg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}