import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "_thumb(@[2-3]x)?\\.jpg";
final String string = "grwior_thumb.jpg\n"
+ "grwior.jpg\n"
+ "vuoetrjrt_thumb@2x.jpg\n"
+ "vuoetrjrt.jpg\n"
+ "hafiruwhf_thumb.jpg\n"
+ "hafiruwhf_thumb@2x.jpg\n"
+ "hafiruwhf_thumb@3x.jpg\n"
+ "hafiruwhf.jpg\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}