import Foundation
let pattern = #"_thumb(@[2-3]x)?\.jpg"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
grwior_thumb.jpg
grwior.jpg
vuoetrjrt_thumb@2x.jpg
vuoetrjrt.jpg
hafiruwhf_thumb.jpg
hafiruwhf_thumb@2x.jpg
hafiruwhf_thumb@3x.jpg
hafiruwhf.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)