re = /_thumb(@[2-3]x)?\.jpg/
str = 'grwior_thumb.jpg
grwior.jpg
vuoetrjrt_thumb@2x.jpg
vuoetrjrt.jpg
hafiruwhf_thumb.jpg
hafiruwhf_thumb@2x.jpg
hafiruwhf_thumb@3x.jpg
hafiruwhf.jpg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end