#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)technology .+ <!-- -->"
Local $sString = "technology capture group examples ending in comments <!-- -->" & @CRLF & _
"technology groups are pretty simple to capture, imo, as long as they end with <!-- --> " & @CRLF & _
"technology groups should remain consistent, if they don't end in <!-- --> it gets weird"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")