package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)technology .+ <!-- -->`)
var str = `technology capture group examples ending in comments <!-- -->
technology groups are pretty simple to capture, imo, as long as they end with <!-- -->
technology groups should remain consistent, if they don't end in <!-- --> it gets weird`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}