$re = '/technology .+ <!-- -->/m';
$str = 'technology capture group examples ending in comments <!-- -->
technology groups are pretty simple to capture, imo, as long as they end with <!-- -->
technology groups should remain consistent, if they don\'t end in <!-- --> it gets weird';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);