re = /technology .+ <!-- -->/m
str = 'technology capture group examples ending in comments <!-- -->
technology groups are pretty simple to capture, imo, as long as they end with <!-- -->
technology groups should remain consistent, if they don\'t end in <!-- --> it gets weird'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end