use strict;
my $str = 'technology capture group examples ending in comments <!-- -->
technology groups are pretty simple to capture, imo, as long as they end with <!-- -->
technology groups should remain consistent, if they don\'t end in <!-- --> it gets weird';
my $regex = qr/technology .+ <!-- -->/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}