const regex = /technology .+ <!-- -->/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('technology .+ <!-- -->', 'gm')
const str = `technology capture group examples ending in comments <!-- -->
technology groups are pretty simple to capture, imo, as long as they end with <!-- -->
technology groups should remain consistent, if they don't end in <!-- --> it gets weird`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}