using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"technology .+ <!-- -->";
string input = @"technology capture group examples ending in comments <!-- -->
technology groups are pretty simple to capture, imo, as long as they end with <!-- -->
technology groups should remain consistent, if they don't end in <!-- --> it gets weird";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}