#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m){[^{}]*?\banimal(\w+)\[name="[^\s"*]*"]"
Local $sString = "Animals {" & @CRLF & _
" idAnimal" & @CRLF & _
" nameAnimal" & @CRLF & _
" animal456jlk165ut[name="Dalty"]" & @CRLF & _
" animal6ljkj[name="Moon"]" & @CRLF & _
"" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"Animals {" & @CRLF & _
" idAnimal" & @CRLF & _
" nameAnimal" & @CRLF & _
" animalk45lil69lhfr5942lk[name="Jazz"]" & @CRLF & _
" animal6ljkjh[name="Pinky"]" & @CRLF & _
" animal595s422d1252g55[name="Steven"]" & @CRLF & _
" animalko5854hg[name="David"]" & @CRLF & _
" animalko5854hg[name="Oty"]" & @CRLF & _
" animalko5854hg[name="Dan"]" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"Animals {" & @CRLF & _
" idAnimal" & @CRLF & _
" nameAnimal" & @CRLF & _
" animalko5854hg[name="Jazz"]" & @CRLF & _
" animal6ljkjh[name="Pinky"]" & @CRLF & _
" animal595s422d1252g55[name="Steven"]" & @CRLF & _
" animalko5854hg[name="David"]" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")