re = /{[^{}]*?\banimal(\w+)\[name="[^\s"*]*"]/m
str = 'Animals {
idAnimal
nameAnimal
animal456jlk165ut[name="Dalty"]
animal6ljkj[name="Moon"]
}
Animals {
idAnimal
nameAnimal
animalk45lil69lhfr5942lk[name="Jazz"]
animal6ljkjh[name="Pinky"]
animal595s422d1252g55[name="Steven"]
animalko5854hg[name="David"]
animalko5854hg[name="Oty"]
animalko5854hg[name="Dan"]
}
Animals {
idAnimal
nameAnimal
animalko5854hg[name="Jazz"]
animal6ljkjh[name="Pinky"]
animal595s422d1252g55[name="Steven"]
animalko5854hg[name="David"]
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end