// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m){[^{}]*?\banimal(\w+)\[name="[^\s"*]*"]"#).unwrap();
let string = "Animals {
idAnimal
nameAnimal
animal456jlk165ut[name=\"Dalty\"]
animal6ljkj[name=\"Moon\"]
}
Animals {
idAnimal
nameAnimal
animalk45lil69lhfr5942lk[name=\"Jazz\"]
animal6ljkjh[name=\"Pinky\"]
animal595s422d1252g55[name=\"Steven\"]
animalko5854hg[name=\"David\"]
animalko5854hg[name=\"Oty\"]
animalko5854hg[name=\"Dan\"]
}
Animals {
idAnimal
nameAnimal
animalko5854hg[name=\"Jazz\"]
animal6ljkjh[name=\"Pinky\"]
animal595s422d1252g55[name=\"Steven\"]
animalko5854hg[name=\"David\"]
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}