const regex = new RegExp('{[^{}]*?\\banimal(\\w+)\\[name="[^\\s"*]*"]', 'gm')
const str = `Animals {
idAnimal
nameAnimal
animal456jlk165ut[name="Dalty"]
animal6ljkj[name="Moon"]
}
Animals {
idAnimal
nameAnimal
animalk45lil69lhfr5942lk[name="Jazz"]
animal6ljkjh[name="Pinky"]
animal595s422d1252g55[name="Steven"]
animalko5854hg[name="David"]
animalko5854hg[name="Oty"]
animalko5854hg[name="Dan"]
}
Animals {
idAnimal
nameAnimal
animalko5854hg[name="Jazz"]
animal6ljkjh[name="Pinky"]
animal595s422d1252g55[name="Steven"]
animalko5854hg[name="David"]
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}