using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{[^{}]*?\banimal(\w+)\[name=""[^\s""*]*""]";
string input = @"Animals {
idAnimal
nameAnimal
animal456jlk165ut[name=""Dalty""]
animal6ljkj[name=""Moon""]
}
Animals {
idAnimal
nameAnimal
animalk45lil69lhfr5942lk[name=""Jazz""]
animal6ljkjh[name=""Pinky""]
animal595s422d1252g55[name=""Steven""]
animalko5854hg[name=""David""]
animalko5854hg[name=""Oty""]
animalko5854hg[name=""Dan""]
}
Animals {
idAnimal
nameAnimal
animalko5854hg[name=""Jazz""]
animal6ljkjh[name=""Pinky""]
animal595s422d1252g55[name=""Steven""]
animalko5854hg[name=""David""]
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}