import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{[^\\{\\}]*?\\banimal(\\w+)\\[name=\"[^\\s\"*]*\"]";
final String string = "Animals {\n"
+ " idAnimal\n"
+ " nameAnimal\n"
+ " animal456jlk165ut[name=\"Dalty\"]\n"
+ " animal6ljkj[name=\"Moon\"]\n\n"
+ "}\n\n"
+ "Animals {\n"
+ " idAnimal\n"
+ " nameAnimal\n"
+ " animalk45lil69lhfr5942lk[name=\"Jazz\"]\n"
+ " animal6ljkjh[name=\"Pinky\"]\n"
+ " animal595s422d1252g55[name=\"Steven\"]\n"
+ " animalko5854hg[name=\"David\"]\n"
+ " animalko5854hg[name=\"Oty\"]\n"
+ " animalko5854hg[name=\"Dan\"]\n"
+ "}\n\n"
+ "Animals {\n"
+ " idAnimal\n"
+ " nameAnimal\n"
+ " animalko5854hg[name=\"Jazz\"]\n"
+ " animal6ljkjh[name=\"Pinky\"]\n"
+ " animal595s422d1252g55[name=\"Steven\"]\n"
+ " animalko5854hg[name=\"David\"]\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}